Upstream processing errors
Incident Report for Pin Payments
Resolved
Our upstream provider has resolved the issue.
Posted 24 days ago. May 26, 2019 - 10:13 AEST
Investigating
An upstream supplier is returning an unusually high number of charge failures. We are investigating the issue. If you receive a charge failure please try again.
Posted 24 days ago. May 26, 2019 - 07:55 AEST
This incident affected: API.