We are currently experiencing an upstream outage which is causing requests to fail. We are investigating the issue.

Incident Report for Pin Payments

Resolved

Normal processing has been resumed.
Posted Jul 28, 2026 - 15:14 AEST

Monitoring

Upstream processing has resumed and processing on Pin has resumed. We are still monitoring the situation.
Posted Jul 28, 2026 - 14:43 AEST

Investigating

We are currently investigating this issue.
Posted Jul 28, 2026 - 14:17 AEST
This incident affected: API, Dashboard, and Payment Page.