System Maintenance
Incident Report for Pin Payments
Resolved
This maintenance window has concluded, all systems are operational.
Posted about 2 years ago. Oct 31, 2016 - 01:00 AEDT
Identified
Maintenance in progress. Charge processing and dashboard access may be unavailable.
Posted about 2 years ago. Oct 31, 2016 - 00:00 AEDT