High rate of charge failures
Incident Report for Pin Payments
Resolved
This incident has been resolved.
Posted over 1 year ago. Mar 28, 2017 - 20:42 AEDT
Monitoring
We are monitoring the results of our service provider's fix.
Posted over 1 year ago. Mar 28, 2017 - 20:32 AEDT
Identified
One of our financial service providers is experiencing technical issues preventing charges from completing. They have been made aware of this and are addressing the issue.
Posted over 1 year ago. Mar 28, 2017 - 20:25 AEDT